Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

TrevorBarry
#1 Posted : Friday, June 8, 2012 3:03:01 PM(UTC)
TrevorBarry
Rank: Newbie

Groups: Member
Joined: 6/8/2012(UTC)
Posts: 3
United Kingdom
Location: Frome

Was thanked: 1 time(s) in 1 post(s)
Hi,

I'm running VS2010 Ultimate on Windows 7 x64.

I want to install v2 of teh T4 Editor but when I try to uninstall v1.0 from control panel I get the message

'There is a problem with this Windows Installer Package. A Program required for this install to complete could not be run. Contact your support personnel or package vendor.'

How can I manually remove v1.0 so that I can install v2.0?

Alternatively, where can I download v1.0 to see if reinstalling it allows me to uninstall it?

Thanks

Trevor

Edited by user Friday, September 7, 2012 7:57:57 PM(UTC)  | Reason: Not specified

 1 user thanked TrevorBarry for this useful post.
TrevorBarry
#2 Posted : Friday, June 8, 2012 3:06:45 PM(UTC)
TrevorBarry
Rank: Newbie

Groups: Member
Joined: 6/8/2012(UTC)
Posts: 3
United Kingdom
Location: Frome

Was thanked: 1 time(s) in 1 post(s)
Some extar information

I found v1.9.65 here - http://t4-editor.tangibl..._Plus_ModelingTools.html

When I try to install this version Windows Installer tells me that 'Another version of this product is already installed. Installation can not continue. Use add/remove programs to remove the program'

so it looks like a manual remove is the only way forward for me.

How do I do that?

Trevor
tangible|Björn
#3 Posted : Friday, June 8, 2012 3:31:01 PM(UTC)
tangible|Björn
Rank: Administration

Groups: Administration
Joined: 3/17/2009(UTC)
Posts: 168
Man
Germany

Was thanked: 12 time(s) in 12 post(s)
There were tools that would help uninstalling a product's MSI when this made problems.
Windows Installer CleanUp Utility or MSIZap. Both seem to be either discontinued by Microsoft or hidden inside larger SDKs.

This MSDN article mentions a new tool: http://support.microsoft...am_Install_and_Uninstall
which could help.
TrevorBarry
#4 Posted : Saturday, June 9, 2012 7:15:36 PM(UTC)
TrevorBarry
Rank: Newbie

Groups: Member
Joined: 6/8/2012(UTC)
Posts: 3
United Kingdom
Location: Frome

Was thanked: 1 time(s) in 1 post(s)
Excellent, thank you.

The tool cleaned everything up nicely and I was able to install v2.0.

Trevor
tangible | Tim
#5 Posted : Wednesday, May 1, 2013 11:09:23 PM(UTC)
tangible | Tim
Rank: Newbie

Groups: Member
Joined: 5/1/2013(UTC)
Posts: 5
Location: Germany

Excellent thanks for letting us know it worked.
Users browsing this topic
Guest (4)
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2020, Yet Another Forum.NET
This page was generated in 0.120 seconds.

Authorization on the site

For an authorized user opens up new possibilities

Login

Password